
Resource Materials
of CWIS Planning
using Base IMIS for
Sanitation
Intervention

Building Intial Understanding

The Necessity and Impact of GIS based Citywide Inclusive Sanitation (G-CWIS)
Training
Scope of ToT Document and Participant’s Prerequisite
Guidelines for Utilizing Training Module
Suggested Training Calendar
Data Checklist and Potential Source

OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Building Footprints using Google Open Buildings
Output Illustrations



Road Network using Open Street Maps (OSM) Database
Output Illustrations
Extraction of Waterbodies and Rivers using Open Street Map (OSM) Database
Output Illustrations
Extraction of Elevation Profile using SRTM or ASTER DEM
Output Illustrations

GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Assessments of Hard to Reach (HTR) Settlements
Stepwise Process Flow Details
Output Application
Assessments of Waterlogging/Flood Prone Settlements
Stepwise Process Flow Details
Output Application
Assessment of Drainage Network with Orders and Density
Stepwise Process Flow Details
Output Application
Assessment for Identifying Settlements Close to Waterbodies
Stepwise Process Flow Details
Output Application
Assessments for Identifying Economic Vulnerability Assessment
Stepwise Process Flow Details
Output Application
Assessment for Settlement Identification for Bulk Volume of Wastewater
Generation
Stepwise Process Flow Details
Output Application
Assessment for Containment Improvement Scheme at Town Scale
Stepwise Process Flow Details
Output Application
Assessments for Public Toilet Gap and Required Upgrades
Stepwise Process Flow Details
Output Application



Assessment of Pan City Level Settlements Proximity to Existing and Proposed
FSTP
Stepwise Process Flow Details
Output Application



Building Intial Understanding



Building Intial Understanding

The Necessity and Impact of
GIS based Citywide Inclusive
Sanitation (G-CWIS) Training
Citywide Inclusive Sanitation (CWIS) is a public service approach that offers significant benefits in
planning, designing, and implementing various ground-level sanitation interventions. CWIS involves
demonstrating improved core system functions at different administrative levels to achieve and
enhance the outcomes outlined under SDG 6 - Safe, equitable, and sustainable sanitation for
everyone in an urban area, with special attention to the needs of the poor and marginalized
groups. The introduction of Geographic Information System (GIS) applications has provided the
CWIS approach with an enriched quantitative layer to its framework, facilitating a more detailed
understanding of potential interventions, even at the building footprint level as part of diverse
assessment processes. The GIS based CWIS (G-CWIS) framework not only aids in comprehending
the challenges and situations at hand but also helps to understand the volume and nature of
required interventions across the value chain. This insight can then be translated into both
investment estimates and robust regulatory provisions. This training has applications across all
scales of city sanitation project planning and design, including components such as greywater and
sewerage systems. Adoption of such innovation has proven to generate evidence-based planning
and assists in optimizing the infrastructure needs for system transformations.



Image not found or type unknown

                                                                                       Figure 1 CWIS Service Framework

Such innovative frameworks are expected to significantly accelerate the SDG 6.2 mandate by
identifying the true beneficiaries and delivering contextual sanitation solutions to safeguard
against sanitation-linked public health and related issues. The G-CWIS framework has been proven
and effective in answering questions like who needs to be served, where such services are
required, and how they should be served. The current version of the framework, constantly
improving based on project experience, has been applied in approximately 25 cities across South
Asian regions, supported by BMGF and through the platform of GWSC, Thailand.

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716270594186.png
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                                                                  Figure 2 Need of GIS based CWIS planning
applications

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716270609397.png


Building Intial Understanding

Scope of ToT Document and
Participant’s Prerequisite
This Training of Trainers (ToT) is designed for GIS practitioners who wish to learn various technical
applications of spatial planning as part of CWIS planning. A prior understanding of GIS software is a
prerequisite for both trainers and trainees involved in any of the training applications. Trainees
participating in this GIS-based training should have foundational knowledge of GIS concepts and
familiarity with open software like QGIS. Proficiency in spatial data management, including
handling formats like Shapefiles is essential. Basic cartographic principles, comprehension of
spatial data collection methods, and understanding of GIS application in their specific field,
particularly in developmentrelated projects, are also required. In case participants lack general GIS
knowledge, a separate training focusing on GIS topics must be provided before this training.

Although the training methods suggested are flexible in nature, trainers are encouraged to explore
their own methods and demonstration techniques during the training sessions. In all
circumstances, a significant focus should be placed on live workshops, making it a mandatory
provision. Close supervision from trainers to the participants will be required as part of these live
sessions.

The participants may span a range of disciplines, including groups from private sectors involved in
WASH-related projects. Furthermore, staff working in urban local bodies, development authorities,
and regional offices, which are involved in providing operational support for WASH to local bodies,
may also be included. This encompasses both urban and rural areas.



Building Intial Understanding

Guidelines for Utilizing
Training Module
For optimal understanding and application of this training module, it is crucial that the outlined
steps are diligently followed.

The training can be delivered both in-person and via an online platform. As a prerequisite,
participants should have pre-installed QGIS software and ensure their laptop or desktop is correctly
configured prior to the training sessions.

All registered participants should receive the training materials, including previous training videos,
before the program commences. This allows them to familiarize themselves with the overall
program and gain a detailed understanding at their own pace.

Any required databases including GIS layers of training session should also be shared with
participants beforehand. These will be utilized during the training sessions, and prior understanding
of data layers would be an added advantage.

For each session, at least 50% of the time should be dedicated to live workshops and practice
sessions, ensuring full participant involvement. The trainer may also incorporate regular group
exercises with opportunities for presentations by each group member.

The introductory session of the training program might also include a brief overview of sanitation
components including introduction of FSM, CWIS, greywater management, sewer system etc. in
context of Global south. which will be beneficial for later stages during workshops and live practical
sessions.
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Suggested Training Calendar
Training Moule Name Practical Session /

Live Workshop
No of hours Suggested Days

I Building initial
understanding

Limited 3 hours 1 days

II Open GIS data
Extractions Process
Framework

High 12 hours 4 days

III Geospatial
Assessments for
CWIS Planning

High 15 hours 5 days

Total Timeline 10 days
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Data Checklist and Potential
Source

Output Maps Data Layer

1. Base map Administrative boundary

  Water bodies

  Road/Rail network

  Land-use

  Building footprints

  Building uses

  Ward-wise population

2. Waterlogged Risk mapping Elevation profile

  Natural drainage density

  Storm water drainage network

3. Flood risk mapping Highest flood level (HFL) of nearby river

  Elevation profile

4. Water proximity settlements mapping Buffer of water bodies

5. Hard to reach settlement mapping Applying buffers on different road width

  In-accessible settlements

  Building footprints

6. LIC Settlements Building structure types (Katcha and Pucca)

7. Public Toilet – upgradation and new units Location of all existing toilets

8. FSTP Proximity Assessment Mapping Building footprints

  Road width and network

  Location of FSTP

9. Greywater management Watershed maps



OPEN GIS DATA
EXTRACTIONS PROCESS
FRAMEWORK



OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Building Footprints using
Google Open Buildings
Stepwise Process Flow Details

Step 1: Access the Data Source o Start by visiting the Google Open Buildings website at
https://sites.research.google/open-buildings/ https://sites.research.google/open-buildings/
o Here you'll find all necessary resources, tools, and information about the building
database you'll be working with.
Step 2: Define your Study Area o Next, define the region of interest for which you want to
extract building data. To do this, visit the polygon selection website at https://arthur
https://arthur-e.github.io/Wicket/sandbox-gmaps3.htmle.github.io/Wicket/sandbox-
gmaps3.html https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
o Use the “Draw a shape tool” to draw your study area, and then copy the resulting code
that defines this polygon.
Step 3: Use the Colab Python Notebook Script o Now, open the Colab Python Notebook
script at open_buildings_spatial_analysis_examples.ipynb - Colaboratory
https://colab.research.google.com/github/google-research/google-
research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
(google.com) https://colab.research.google.com/github/google-research/google-
research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynbo
Paste the code of your study area (from Step 2) into the designated area in the Colab
notebook. After that, run the script. This will initiate the process of extracting data for
buildings located within your selected area.
Step 4: Authenticate your Google Drive o The script requires access to your Google Drive
to store the resulting data. Follow the prompts of the script to authenticate your Google
Drive. This will typically involve clicking on a link, signing into your Google account, and
then copying and pasting an authentication code back into the script.
Step 5: Extract and Save the Building Data o Upon successful authentication, the script
will then proceed to extract the building data and save it into your Google Drive in a CSV
(commaseparated values) format.
Step 6: Download and Load the Data into QGIS
o Next, go to your Google Drive, find the saved CSV file, and download it onto your
computer. Then, open your QGIS software, and load the CSV file into it.

https://sites.research.google/open-buildings/
https://sites.research.google/open-buildings/
https://sites.research.google/open-buildings/
https://sites.research.google/open-buildings/
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://arthur-e.github.io/Wicket/sandbox-gmaps3.html
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb
https://colab.research.google.com/github/google-research/google-research/blob/master/building_detection/open_buildings_spatial_analysis_examples.ipynb


Step 7: Validate the Data o To ensure the data is accurate and up to date, overlay the
building boundaries onto the latest Google imagery available in QGIS. Check each building
and make sure they are correctly represented. If there are any missing buildings, you can
add them manually.
Step 8: Export the Data o After validation, you can now prepare your data for further use.
Export the building data as a shapefile, which is a common format used for geospatial
vector data.
Step 9: Clip the Data to your Study Area o The last step is to clip the data to your defined
study area. Select "Vector" > "Geoprocessing Tools" > "Clip" from the top menu. Select
the Input layer as the building data shapefile and the Overlay layer as your study area
boundary. This will remove any buildings that fall outside of your region of interest,
resulting in a clean and concise dataset that only includes the buildings you are interested
in.



OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Output Illustrations
Image not found or type unknown

Figure 3 Illustrations of built-up extractions, Dhanbad (India).

Source – Dhanbad spatial analysis, Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716271647379.png


OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Road Network using Open
Street Maps (OSM) Database
Stepwise Process Flow Details

Step 1: Load the Study Area Boundary in QGIS o Start your QGIS software and load the
boundary file of your study area.
You can do this by clicking on "Layer" in the top menu, then selecting "Add Layer" > "Add
Vector Layer" and navigating to the file on your computer.
Step 2: Install the OSM Downloader Plugin in QGIS o To download the data from
OpenStreetMap, you will need a specific plugin. From the top menu, select "Plugins" >
"Manage and Install Plugins". Search for "OSM Downloader" and install it.
Step 3: Select the Area of Interest Using the OSM Downloader Plugin o Use the OSM
Downloader plugin to select your area of interest. You can do this by selecting "Plugins"
from the top menu, then "OSM
Downloader" > "Download Data". A map will appear where you can draw a rectangle
around your area of interest.
Step 4: Download and Save the OSM Data o Once you've selected the area, click "OK" to
start the download. The data will be saved as a .osm file on your computer.
Step 5: Select Only Road-Type Polyline Features from the Downloaded OSM
Data o Now, load the downloaded the .osm data into QGIS by clicking on "Layer" in the
top menu, then "Add Layer" > "Add Vector Layer". In the layer list, find and select the
"lines" layer, which contains the road data. Right-click on the "lines" layer and select
"Open Attribute Table". Here, you can select and isolate only the road-type polyline
features.
Step 6: Export the Selected Road Data as a Shapefile o Once you've selected the road
data, right-click on the "lines" layer in the layer list and select "Export" > "Save Features
As". Choose the format as "ESRI Shapefile" and choose the location on your computer
where you want to save it.
Step 7: Clip the Shapefile to your Study Area o You will now clip the road data shapefile
to your study area. Select
"Vector" > "Geoprocessing Tools" > "Clip" from the top menu. In the Clip
tool, set the Input layer as the road data shapefile and the Overlay layer as your study
area boundary. Run the tool to clip the road data to your study area.
Step 8: Recategorize the Road Types o Finally, you may want to recategorize the road
types to match the government categories such as National Highway, State Highway, etc.
Open the attribute table of the clipped road data shapefile and manually edit the road
type categories to align them with the government standards.





OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Output Illustrations
Image not found or type unknown

Figure 4 Illustrations of road network extracted from open source, Tarabo (Bangladesh):

                                                                                                        Source – CWIS spatial analysis,
Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716272201664.png


OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Extraction of Waterbodies
and Rivers using Open
Street Map (OSM) Database
Stepwise Process Flow Details

Step 1: Download OpenStreetMap (OSM) Data for Your Study Area o Start by loading your
study area in QGIS and using the OSM Downloader plugin to download the OSM data for
your area of interest, as explained in the previous steps. This data will be saved as an
.osm file on your computer.
Step 2: Load OSM Data into QGIS o Next, load the downloaded .osm data into QGIS by
navigating to "Layer" in the top menu, then selecting "Add Layer" > "Add Vector Layer".
Browse to the location of your .osm file and load it into QGIS.
Step 3: Select Waterbody and River Features o In the OSM data, the water bodies and
rivers are generally contained in the 'multipolygons' layer. In the layer list, select the
'multipolygons' layer and then right-click to select "Open Attribute Table". This will bring
up a list of all features in this layer. o From here, filter and select the features that
represent water bodies or rivers. This can be done by setting up a query in the attribute
table where the 'type' or 'name' of the feature represents water bodies or rivers.
Step 4: Export Selected Features as a Shapefile o Once you've selected the relevant
waterbody and river features, you can export them as a shapefile for further analysis. To
do this, right-click on the 'multipolygons' layer in the layer list and select "Export" > "Save
Features As". Choose "ESRI Shapefile" as the format and select a location on your
computer to save the file.
Step 5: Clip the Shapefile to Your Study Area o Finally, use the clip tool to trim your
shapefile to match the boundaries of your study area. Navigate to "Vector" >
"Geoprocessing Tools" > "Clip" in the top menu. Set the input layer as the waterbody and
river shapefile and the overlay layer as your study area boundary. Run the tool to perform
the clipping operation. The result is a shapefile that contains only the water bodies and
rivers within your study area.



OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Output Illustrations
Image not found or type unknown

Figure 5 Illustrations of extracted water bodies map, Ranchi (India)

Source – CWIS spatial analysis, Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716272518289.png


OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Extraction of Elevation
Profile using SRTM or ASTER
DEM
Stepwise Process Flow Details

Step 1: Install the SRTM Downloader Plugin o Open QGIS. o Go to the Plugins menu. o
Select "Manage and Install Plugins." o In the Plugins dialog, search for "SRTM
Downloader." o Click on the plugin and then click the "Install Plugin" button to install.
Step 2: Access the SRTM Downloader Plugin o Once the plugin is installed, you should see
a new menu item called "SRTM Downloader" in the QGIS toolbar.
Step 3: Define Study Area o Zoom in to your study area in QGIS using the zoom and pan
tools.

Use the rectangle or polygon selection tool to define the area you want to download
the SRTM data for. You can find these selection tools in the QGIS toolbar.

Step 4: Run the SRTM Downloader Plugin o Click on the "SRTM Downloader" menu in the
QGIS toolbar. o Login using the Earthdata user account.

In the SRTM Downloader dialog, choose the output folder where you want to save
the downloaded data.

Step 5: Start the Download o Click the "OK" button to start the download process. The
plugin will automatically download the SRTM data for the defined study area.
Step 6: Process the Downloaded Data o Once the download is complete, the SRTM data
will be available in the output folder you specified. o You can now use the downloaded
SRTM data for your analysis in QGIS.



OPEN GIS DATA EXTRACTIONS PROCESS FRAMEWORK

Output Illustrations
Image not found or type unknown

Figure 6 Illustrations of extracted elevation profile, Ranchi (India)

Source – CWIS spatial analysis, Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716272897857.png
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GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Assessments of Hard to
Reach (HTR) Settlements
Data Requirements

Road Network with road width or categories
Building footprint and type of building



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Stepwise Process Flow
Details

Step 1: Prepare the Data o Gather geospatial data on building locations and road
networks in compatible formats, such as shapefiles or geodatabases.
Step 2: Overlay Data o Open QGIS and add the building and road network layers to your
project. o Ensure that both layers are loaded into the Layers Panel and visible in the map
view. o Categorize the road network layer based on road types using the "Categorized" or
"Rule-based" symbology options.
Step 3: Buffer Analysis (100 feet) o Go to the Processing Toolbox (Processing > Toolbox)
to access geoprocessing tools.

Under "Vector geometry," find and open the "Fixed distance buffer" tool. o Select the
road network layer as the "Input layer" and set the "Buffer distance" to 100 feet (or
any desired distance).
Specify the output file name and location. o Click "Run" to create the 100-feet buffer
zones around the road networks.

Step 4: Identify Buildings within the 100-feet Buffer o Still in the Processing Toolbox,
search for and open the "Intersection" tool. o Select the buildings layer as the "Input
layer" and the buffer layer (created in Step 3) as the "Overlay layer."

Set the output file name and location for the intersected buildings. o Click "Run" to
find the buildings that fall within the 100-feet buffer zones.

Step 5: Buffer Analysis for Additional Distance (200 feet) o Repeat the same buffer
process as in Step 3, but this time set the buffer distance to 200 feet (or any desired
distance). o Create a new buffer zone around the road networks.
Step 6: Identify Inaccessible Buildings o In the Processing Toolbox, run the "Symmetrical
difference" tool.
Select the buildings layer as the "Input layer" and the combined 100-feet and 200-feet
buffer layers as the "Overlay layer."

This operation will identify buildings that are outside both buffer zones, which are
the "Inaccessible Buildings."

Now, you should have three categories of buildings: those within 100 feet of roads, those between
100 feet and 200 feet, and those more than 200 feet away (inaccessible buildings). The results will
be stored in separate layers based on your specified output file names and locations.
Image not found or type unknownImage not found or type unknown
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Figure 7 Illustrations of town desludging schemes based on hard-to-reach area findings,
Sherpur (Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Output Application
The output here provides a clear understanding of the settlements accessible by large and small
volume trucks. It pinpoints areas requiring additional infrastructure such as pipes and electric
pumps and identifies inaccessible areas where manual or electric small carts are necessary for
mechanical desludging.

As for its application, such framework can be instrumental in designing a desludging scheme for
any towns. It aims to ensure a 100% safe collection mechanism for all users, effectively integrating
data, analysis, and visualization to assist in efficient decisionmaking and strategy formulation for
sludge emptying and collections.



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Assessments of
Waterlogging/Flood Prone
Settlements
Data Requirements

1. Elevation data
2. Waterbodies/ Rivers
3. Past Flood data with location
4. High Flood Line for rivers



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Stepwise Process Flow
Details

Step 1: Import Data o Open QGIS and load your Digital Elevation Model (DEM) data
representing the topography of the study area. o Import building data and any other
relevant spatial data layers, such as rivers, flood-prone areas, and historical flood level
data, if available.
Step 2: Clip the Digital Elevation Model o Use the "Clip raster by extent" tool to clip the
DEM to your study region. This tool can be found in the Processing Toolbox (Processing >
Toolbox) under the GDAL > Raster extraction menu.
Step 3: Reclassify the DEM o Utilize the "Reclassify by table" tool in the Processing
Toolbox (Processing > Toolbox) under the SAGA > Raster tools menu.
o In the tool dialog, select the clipped DEM as the input raster, and define your flood
threshold values in a reclassification table (e.g., set values less than the High Flood Line
(HFL) to 1 and the rest to 0).
Step 4: Identify Flood-Prone Areas o After reclassifying the DEM, the resulting raster
image will represent potential flood-prone areas, where cells with a value of 1 are
susceptible to flooding.
Step 5: Use Historical Flood Levels (if available) o If you have access to historical flood
level data, repeat Steps 2 and 3 with this data to create an additional raster representing
historical flood-prone areas.
Step 6: Overlay Buildings o Add the building data to QGIS and ensure it aligns correctly
with the other layers. o Use the "Intersect" tool in the Processing Toolbox (Vector overlay
> Intersection) to overlay the buildings layer with the flood-prone areas layer. This will
help identify buildings falling within the flood-prone regions.

Image not found or type unknown

Figure 8 Illustrations of identifying of water logging prone settlements, Sherpur
(Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716273796305.png


GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Output Application
Areas with waterlogging risks present operational challenges for the smooth functioning of toilet
units. These challenges include toilet back-flow and non-functional soak pits. Understanding such
risk areas may aid in understanding such risk hot spots on at city scale and integrating them with
building bye-laws could also assist in the development of an appropriate monitoring framework.



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Assessment of Drainage
Network with Orders and
Density
Data Requirements

1.     Elevation data
2.     Waterbodies/ Rivers



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Stepwise Process Flow
Details
Step-by-step instructions in paragraph form for identifying natural drainage network and catchment
areas from DEM using QGIS Hydrology tools:

Step 1: Load the DEM for the Study Area o Open QGIS and add the DEM layer to your
project by navigating to
'Layer' > 'Add Layer' > 'Add Raster Layer'. Browse and select your DEM file.
Step 2: Clip the DEM o To clip the DEM to a region larger than the study area, go to
'Raster' > 'Extraction' > 'Clip Raster by Extent'. o Select your input DEM layer and define
the extent to cover an area larger than your study region.

Set the output file and click 'Run'.
Step 3: Fill and Interpolate Gaps in the DEM and generate Flow Direction Raster o Install
the 'SAGA' processing provider if you haven't already. Go to 'Processing' > 'Toolbox'. o In
the processing toolbox, search for 'Fill Sinks (Wang & Liu)' and run the tool. o Select the
clipped DEM as the input, set the 'Output corrected DEM' file, and run the tool.

This will generate both Filled DEM and Flow direction raster files
Step 5: Generate the Stream Network o In the processing toolbox, search for 'Flow
Accumulation' and run the tool. o Choose the flow direction grid (generated in the
previous step) as the input and set the 'Flow accumulation grid' as the output.
Step 6: Use the Raster Calculator Tool o In the processing toolbox, search for 'Raster
Calculator' and run the tool. o Enter the expression to select pixels greater than a certain
threshold (e.g., 5% of the maximum flow accumulation value). o Example:
"flow_accumulation@1 > 0.05 * max_flow_accumulation_value" (Replace
'max_flow_accumulation_value' with the actual maximum value). o Set the output raster
file and run the tool.
Step 7: Define the Stream Order o In the processing toolbox, search for 'Strahler Stream
Order' and run the tool. o Choose the flow direction grid and the stream network raster
(generated in the previous step) as inputs. o Set the output file and run the tool.
Step 8: Convert to Polygon o In the processing toolbox, search for 'Raster to Polygon' and
run the tool. o Select the stream order raster (generated in the previous step) as the input
and set the output file.
Step 9: Generate the Drainage Network o The stream polygons obtained from the
previous step represent the drainage network classified according to stream order.
Step 10: Create a New Shapefile o To delineate catchment areas and outfall locations,
you can use a combination of 'Raster Calculator' and 'Raster to Polygon' tools to extract
catchment boundaries from the flow accumulation raster. Then, manually digitize outfall



points as new vector points in a new shapefile.

With these steps, you will be able to identify the natural drainage network and catchment areas
from the DEM data using QGIS.
Image not found or type unknownImage not found or type unknown

Figure 9 Illustrations of watershed regions at Dhanbad (India)

Source – CWIS spatial analysis, Innpact Solutions and GWSC

http://152.42.244.158/knowledge-product/uploads/images/gallery/2024-05/image-1716275331131.png


GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Output Application
A drainage network map helps delineate the different watersheds within a region, which play a
significant role in both sewer and non-sewer zoning for any large town. Furthermore, watershed
zones have significant applications in grey water management using an interceptor and diversion
(I&D) framework. They can serve as functional linkages with the sewer system or may also operate
as independent modules. Further this also has applications in identifying water logged prone area
within the city. 



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Assessment for Identifying
Settlements Close to
Waterbodies
Data Requirements

Waterbodies/ Rivers
Building footprint



GEOSPATIAL ASSESSMENTS FOR CWIS PLANNING

Stepwise Process Flow
Details
Stepwise Process Flow Details

Step 1: Overlay the Data Layers
Start by overlaying the water bodies, rivers, and building data layers on your map in the
QGIS software. This involves using the 'Add Layer’ feature to import the necessary layers
into your map document. Ensuring that all these layers are on the same coordinate
system is crucial for achieving accurate results.
Step 2: Conduct Buffer Analysis
Next, perform a buffer analysis around the water bodies and rivers. Use the 'Buffer' tool
within the ‘Vector Geometry’ section of the ‘Processing Toolbox’ menu. For water bodies,
create a buffer of 30 feet and for rivers, create a buffer of 100 feet. This process
essentially draws a boundary around the specified features (in this case, water bodies and
rivers) at a set distance.
Step 3: Identify Buildings within Buffer Regions
Having established your buffer zones, it's now time to identify the buildings within these
areas. To do this, use the 'Select by Location' tool. This tool allows you to select features
(in this case, buildings) based on their geographic relationship to features within another
layer (in this case, the buffer zones). Ensure you select the buildings that fall within the
buffer regions that you created in the previous step.
Step 4: Categorize Buildings
Finally, classify all buildings that have been identified within the buffer regions as 'Water
Proximity Buildings'. This can be done by creating a new field in the attribute table of the
building layer and assigning these buildings with a specific tag or code.
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Figure 10 Illustrations for identifying settlements close to water bodies, Sherpur

Source – CWIS spatial analysis , Innpact Solutions and GWSC
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Output Application
Areas in proximity to water tend to have a heightened risk of untreated wastewater encroaching
into nearby water bodies, which can have significant public health and environmental ramifications.
Identifying such settlements can guide the selection of safe containment provisions in both existing
and upcoming units. These units can also be integrated with building by-laws and ensure safe
containment provisions in all future constructions. 
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Assessments for Identifying
Economic Vulnerability
Assessment
Data Requirements

1. Building footprint with Typology
2. Slum boundary
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Stepwise Process Flow
Details

Step 1: Determine the Building Typology
The first step involves examining the building data you've collected. If the data includes
information on building typology, you can use this to identify all buildings with 'kutcha'
construction - a term used in South Asia to refer to buildings made from materials such as
mud, thatch, or bamboo. These structures are typically associated with economically
vulnerable households.
Step 2: Use Slum Boundaries
If the building typology data is not available, you can use slum boundaries as an indicator
of economically vulnerable settlements. Slums are often characterized by overcrowded
and inadequate housing conditions and can be an indicator of economic vulnerability. If
you have this boundary data, overlay it onto your existing map in the GIS software.
Step 3: Conduct Overlay Analysis
Having established the criteria for economic vulnerability (either kutcha construction or
location within slum boundaries), perform an basic overlay analysis by using the tool,
‘select by location’ in QGIS software.
Step 4: Categorize Buildings
The final step is to categorize the buildings or settlements identified through the overlay
analysis as 'Economically Vulnerable Settlements'. This can be done by creating a new
field in the attribute table of the building layer and assigning these buildings with a
specific tag or code.
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Figure 11 Illustrations for identifying economic vulnerable settlements, Sherpur
(Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC
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Output Application
Settlements identified as economically vulnerable are given priority when designing and
implementing sanitation interventions across the sanitation value chain. These settlements can
also be overlaid with other environmental and climate risk outputs to identify those with a higher
degree of vulnerability.
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Assessment for Settlement
Identification for Bulk
Volume of Wastewater
Generation
Data Requirements
1. Building with type of use and number of floors
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Stepwise Process Flow
Details

Step 1: Gather Building Data
The initial step in the process involves gathering the relevant building data. This includes
a building-level land-use map which details the characteristics of each building such as its
type (e.g., residential, institutional), the number of floors it has, and other relevant data.
Step 2: Import Data into GIS
Import this data into your QGIS document. Make sure the data is correctly georeferenced
to ensure accurate analysis.
Step 3: Identify Key Buildings
Next, use a selection query to identify key buildings that are likely to generate large
volumes of wastewater. This includes high-rise buildings (those with more than three
floors), apartment complexes, and institutional buildings such as residential schools,
colleges, and hospitals.
Step 4: Categorize Buildings
Having identified these key buildings, categorize them as 'Bulk Wastewater Generators'.
You can create a new field in the building layer's attribute table for this category, and
assign each of the identified buildings to this new category.
Step 5: Visualize and Analyze
Finally, visualize these buildings on the map for a clear understanding of their distribution
across the city. This could involve using different colors or symbols to represent the
different categories of buildings. Analyze the spatial pattern of these buildings for insights
into the bulk wastewater generation in the city.
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Figure 12 Illustrations of identifying settlements of bulk wastewater volume generator,
Sherpur (Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC
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Output Application
Buildings that produce significant wastewater should be prioritized for on-site treatment,
particularly if they're near water-sensitive areas, given the considerable environmental and health
risks. Recognizing these bulk generators can guide us in two ways. For government buildings, we
can suggest interventions and financial aid to establish on-site wastewater systems. For private
buildings, regulation and monitoring can gradually improve conditions. Including these generators
in building bye-laws ensures future buildings consider wastewater management, promoting both
immediate and long-term improvement
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Assessment for Containment
Improvement Scheme at
Town Scale
Data Requirements

1. Output map of settlement near to water bodies,
2. Output map of settlement with waterlogged and flood prone risk
3. Output map of hard-to-reach settlement area
4. Output map of bulk wastewater generator building
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Stepwise Process Flow
Details

Step 1: Gather Spatial Layers of Containment Risk This initial step involves the collection
of spatial layers that map various types of containment risks. These might include data on
settlements near water bodies, waterlogged areas, flood-prone regions, hard-to-reach
settlements, and locations of bulk wastewater generators.
Step 2: Overlay Risk Layers on City Building Footprints Once the necessary spatial layers
have been collected, these layers can be overlaid on a city-wide map of building
footprints. This process visualizes the proximity of each building to the various
containment risks identified in Step 1. GIS software like QGIS is typically used for this
process.
Step 3: Understand City-Wide Risk at Building Level After the risk layers have been
overlaid on the building footprints, it is possible to start understanding the distribution of
risks across the city. Different color codes can distinguish between safe zones and risk
areas. Within the risk areas, further categorization by typology can highlight different
levels or types of risks. This may include different colors or symbols for buildings that are
close to water bodies, located in flood-prone areas, hard to reach, or generate large
amounts of wastewater. This city-wide risk understanding will provide a comprehensive
view of the containment challenges at the building level.
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Figure 13 Illustrations of developing containment improvement scheme, Sherpur
(Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC
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Output Application
Location-based information can assist in tracking the evolution of improved containment systems
over time. Such data also offers crucial insights for shaping city sanitation regulations, thereby
facilitating an understanding of overall containment improvement objectives and designing service-
level benchmarks for ongoing monitoring. Moreover, this information can be integrated with
building bye-laws to ensure the selection of contextually appropriate containment systems in all
future construction projects.
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Assessments for Public Toilet
Gap and Required Upgrades
Data Requirements

1. Major commercial and institutional land uses
2. Network Dataset using the road network layer
3. Location of public toilets with number of seats
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Stepwise Process Flow
Details

Step 1: Assess the Walkability Factor
For this process, a network analysis of the study region is necessary. This involves the
creation of a network dataset.
Step 2: Create a Network Dataset
The road network shapefile must be clean and free from any topology errors.
After ensuring the integrity of the shapefile, create a network dataset. o Ensure you have
the "QNEAT3" plugin installed in your QGIS.
o Load your road network shapefile in QGIS. o Use the "QNEAT3 > Create Network from
Layer" tool to create a network dataset.
This will initiate the creation of a network dataset using the road layer.
Step 3: Conduct a Proximity Study
Use the "QNEAT3 > Service Area (from Layer)" tool to conduct a proximity study using the
locations of existing public toilets as input data.
Step 4: Create a Network Buffer
For each public toilet, create a network buffer representing a walkability distance of 500
feet.
Step 5: Overlay the Data with Commercial Land Use
Use the "Vector > Geoprocessing Tools > Intersect" tool to overlay the buffer data with
the commercial land use data. This will help you identify major commercial areas and
public places outside the walkability region of the public toilets.
Step 6: Identify New Toilet Locations
Based on the overlay analysis, pinpoint potential locations for new toilets. These should be
in areas currently underserved by the existing public toilets, particularly in commercial
and high traffic areas.
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Figure 14 Illustrations of public toilet assessment of Sherpur, Bangladesh

Source – CWIS spatial analysis, Innpact Solutions and GWSC
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Output Application
Implementing and adapting these recommendations would contribute to an adequate distribution
and coverage of public toilet services throughout the city. A primary focus is on achieving a
balanced gender distribution of water closets (WCs). Common observations across various cities
have revealed a significant shortage of women's facilities in public toilet premises. Therefore,
alongside general upgrades, there is a proposal to establish dedicated 'She Toilets' in high footfall
areas to meet this demand.
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Assessment of Pan City
Level Settlements Proximity
to Existing and Proposed
FSTP
Data Requirements

1. Location of existing and proposed FSTPs
2. Network dataset using the road network layer
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Stepwise Process Flow
Details

Step 1: Load the Network Dataset
Load the road network shapefile in QGIS, which you created earlier as a network dataset.
Step 2: Add FSTP Locations
Add the locations of the existing and proposed FSTPs as input data for the network
analysis.
Step 3: Create Network Buffers
To create network buffers representing travel times of 15 minutes, 30 minutes, and
greater than 30 minutes for truck travel from each FSTP, you can use the "QNEAT3 >
Service Area (from Layer)" tool. Select the FSTP locations as the input points. Configure
the travel time intervals (15 minutes, 30 minutes, and greater than 30 minutes). Run the
tool to create the network buffers centered on the FSTP locations.
Step 4: Overlay Buffers on Settlement Data
Overlay the network buffers onto the settlement dataset. This can usually be
accomplished by using an 'Overlay' or 'Intersect' function within your GIS software.
Step 5: Overlay Buffers on Settlement Data
Overlay the network buffers onto the settlement dataset by using the "Vector >
Geoprocessing Tools > Intersect" tool in QGIS.
Select the settlement dataset as the input layer and the network buffers as the overlay
layer. Run the tool to create a new layer containing the intersected features.
Step 6: Identify Buildings within Buffers
Identify and categorize the buildings within each buffer zone using the "Vector > Research
Tools > Select by Location" tool in QGIS.
Select the buildings layer as the target layer.
Choose the buffer zones (15-minute travel time, 30-minute travel time, and greater than
30-minute travel time) as the source layer.
Select the "Intersect" spatial selection method to find buildings within each buffer zone.
Create a new layer with the selected buildings for each buffer category.
Step 7: Calculate Percentages
Calculate the percentage of buildings accessible within each of the buffer categories.
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Figure 15 Illustrations of assessment of settlements proximity of proposed and existing
FSTP, Sherpur (Bangladesh)

Source – CWIS spatial analysis, Innpact Solutions and GWSC
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Output Application
This type of analysis aids in assessing the locational suitability of both existing and proposed
Faecal Sludge Treatment Plant (FSTP) sites. Based on the results, areas outside of smooth travel
distances might consider the possibility of implementing transfer stations or additional treatment
facilities, contingent on the volume of sludge generated from their respective settlement areas.
This spatial understanding provides a comprehensive approach for faecal sludge management
planning and implementation across the city.


